Текущее время: 10 дек 2019, 18:28 • Часовой пояс: UTC + 3 часа
Сообщения без ответов | Активные темы

Проблемы со звуком ТВ-Тюнера

Начать новую темуОтветить на тему Страница 1 из 1 [ Сообщений: 3 ]
Версия для печати Пред. тема | След. тема
АвторСообщение
Сообщение Добавлено: 13 фев 2011, 20:05. Заголовок сообщения:  Проблемы со звуком ТВ-Тюнера
Зарегистрирован:
    13 фев 2011, 19:51
Сообщения: 1
Здравствуйте!
Уважаемые форумчане, пожалуйста помогите решить проблему со звуком тв тюнера в Debian Release 6.0 Squeeze, ядро 2.6.32-5-amd64.

Проблема вот в чем:

У меня стоит тв-тюнер Compro TV Videomate и звуковая карта SB Audigy 5.1(не встроенная). Звук работает, музыку слушать можно, также тюнер показывает, но нет звука от тюнера. Если вставить колонки напрямую в тюнер, то звука тоже нет.

В Windows эта парочка работает и звук есть через шину PCI.

в Linux я создал файл /etc/modprobe.d/saa7134.conf такого содержания:

alias char-major-81 videodev
alias char-major-81-0 saa7134
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off
alias char-major-89-* i2c-dev
options saa7134 card=90 tuner=10 i2c_scan=1

У меня стоит две звуковые карты, но выставил по умолчанию карту PCI SB Audigy(SB-24-bit) звук 5.1. Она у меня в системе под номером 1.

dmesg | grep saa7134 выдает:

[ 6.053252] saa7134 0000:04:04.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 7.324436] saa7134 ALSA driver for DMA sound loaded

А команда dmesg | grep saa выдает:

[ 6.053222] saa7130/34: v4l2 driver version 0.2.15 loaded
[ 6.053252] saa7134 0000:04:04.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 6.053256] saa7133[0]: found at 0000:04:04.0, rev: 209, irq: 17, latency: 32, mmio: 0xfbefe000
[ 6.053261] saa7133[0]: subsystem: 185b:c100, board: Kworld ATSC110/115 [card=90,insmod option]
[ 6.053340] saa7133[0]: board init: gpio is 4c003f
[ 6.053348] IRQ 17/saa7133[0]: IRQF_DISABLED is not guaranteed on shared IRQs
[ 6.203504] saa7133[0]: i2c eeprom 00: 5b 18 00 c1 ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203509] saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203513] saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203517] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203521] saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203525] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff 04 ff 00 05 30 33 cb
[ 6.203529] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203533] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203537] saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203541] saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203545] saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203549] saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203553] saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203557] saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203561] saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.203565] saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6.223500] saa7133[0]: i2c scan: found device @ 0xa0 [eeprom]
[ 6.231483] saa7133[0]: i2c scan: found device @ 0xc0 [tuner (analog)]
[ 6.239434] saa7133[0]: i2c scan: found device @ 0xc2 [???]
[ 6.245245] saa7133[0]: Unable to enable tuner(0).
[ 6.245419] saa7133[0]: Unable to enable tuner(1).
[ 6.245592] saa7133[0]: Unable to enable tuner(2).
[ 6.245765] saa7133[0]: Unable to enable tuner(3).
[ 6.245939] saa7133[0]: Unable to enable tuner(4).
[ 7.069676] tuner 1-0060: chip found @ 0xc0 (saa7133[0])
[ 7.170387] saa7133[0]: registered device video0 [v4l2]
[ 7.170403] saa7133[0]: registered device vbi0
[ 7.232349] saa7133[0]/dvb: frontend initialization failed
[ 7.324436] saa7134 ALSA driver for DMA sound loaded
[ 7.324442] IRQ 17/saa7133[0]: IRQF_DISABLED is not guaranteed on shared IRQs
[ 7.324453] saa7133[0]/alsa: saa7133[0] at 0xfbefe000 irq 17 registered as card -1

Смотрю ТВ через tvtime.

Видел отзывы что нужно звук перенаправлять, но скрипт который здесь на форуме советуют не работает, а именно скрипт от igk72:

#!/bin/sh
if [ -f /usr/bin/arecord ]; then
arecord -q -D hw:1,0 -r 32000 -c 2 -f S16_LE | aplay -q - &
fi

if [ -f /usr/bin/tvtime ]; then
tvtime -m --mixer=/dev/mixer:pcm --xmltv=/var/lib/tvtime/tvguide.xml
fi

pid=`pidof arecord`

if [ $pid ]; then
kill -9 $pid
fi

После запуска этого скрипта выдает сообщение:

aplay: main:654: audio open error: Устройство или ресурс занято
Запуск tvtime 1.0.2.
Чтение конфигурации из /etc/tvtime/tvtime.xml
Чтение конфигурации из /root/.tvtime/tvtime.xml
I/O warning : failed to load external entity "/var/lib/tvtime/tvguide.xml"
xmltv: Can't open file /var/lib/tvtime/tvguide.xml.


Кто чем может помогите и скажите что можно сделать чтобы можно было смотреть тв со звуком, буду очень благодарен!

С Уважением ко всем Вам!
Профиль 
Сообщение Добавлено: 15 фев 2011, 19:05. Заголовок сообщения: 
Зарегистрирован:
    01 окт 2009, 16:44
Сообщения: 26
Откуда: Черноголовка
попробуйте mythtv

мне оно помогло, но потом я сдуру стер все настройки
сейчас настраиваю заново
Профиль WWW 
Сообщение Добавлено: 23 окт 2011, 16:41. Заголовок сообщения:  Re: Проблемы со звуком ТВ-Тюнера
Зарегистрирован:
    23 окт 2011, 16:01
Сообщения: 10
Цитата:
1. tvtime -m --mixer=/dev/mixer:pcm --xmltv=/var/lib/tvtime/tvguide.xml

После запуска этого скрипта выдает сообщение:
aplay: main:654: audio open error: Устройство или ресурс занято
Запуск tvtime 1.0.2.
Чтение конфигурации из /etc/tvtime/tvtime.xml
Чтение конфигурации из /root/.tvtime/tvtime.xml
2. I/O warning : failed to load external entity "/var/lib/tvtime/tvguide.xml"
xmltv: Can't open file /var/lib/tvtime/tvguide.xml.

1. Нет в новом дебиане устройства с названием mixer.
2. Ты программу передач по указанному адресу загрузил? ("/var/lib/tvtime/tvguide.xml")
Нет, так какого????

P.S. Блин, когда читать-то научитесь, все- ж н аписано :-)
Профиль 
Показать сообщения за:  Поле сортировки:    
Начать новую темуОтветить на тему  Страница 1 из 1  [ Сообщений: 3 ]  
Кто сейчас на конференции
Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения
Найти:  
Перейти: